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The following are step-by-step instructions for using AstroImageJ (AIJ) to perform the 
reduction and analysis of an exoplanet observation. Many thanks to Grady Boyce of the Boyce 
Research Initiatives and Education Foundation (B.R.I.E.F – www.boyce-astro.org) for initiating 
this “cookbook” and for its initial version. Comments on and suggestions for improvements to 
the instructions below can be forwarded to Dennis Conti at dennis@astrodennis.com. A link to 
the latest version of these instructions can be found at TBD. 
 
These instructions supplement Section 7.0 of “A Practical Guide to Exoplanet Observing,” a link 
to the latest version of which can be found at www.astrodennis.com and which will be 
referred to in the instructions below as “the Practical Guide.” Note that the instructions below 
are not a substitute for the Practical Guide, but rather are a supplement to it. Reference will 
also be made below to “the Worksheet” – this is the worksheet depicted in Appendix A of the 
Practical Guide and which, when filled out per the instructions in the Practical Guide, will be 
useful in conducting the phases described below. 
 
In addition to the Practical Guide, reference will sometimes be made to AstroImageJ’s own 
guide, which can be found at www.astro.louisville.edu/software/astroimagej/ and which will 
be referred to here as “the AIJ Guide.” 
 
Some text in this guide will differentiated with red, underlined textx and a number in 
superscript. This indicates a file required for upload to ExoFOP-TESS or ExoFOP-K2. The number 
in superscript indicates which file this correlates to in the TFOP_SG1_Guidelines.  
 
Legend: 
 

 
Figure 1. AIJ Main Toolbar 
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Figure 2. CCD Data Processor Window 

 

 
Figure 3. DP Coordinate Converter 

 



 
Figure 4. Image Display Window 

 

 
Figure 5. Seeing Profile Window 

 



 
Figure 6. Multi-Aperture Measurements Window 

 

 
Figure 7. Aperture Photometry Settings Window 

 
 



Figure 8. Measurement Table Window after processing is complete. 
 

 
Figure 9. Plot of Measurements. 

 

 
Figure 10. Multi-plot Y-data window. 

 



 
Figure 11. Multi-plot Reference Star Settings window. 

 

 
Figure 12. Multi-plot Main window. 

 



 
Figure 13. Data Set 2 Fit Settings window. 

 
 
 
 
 
 
 
 

  



 
Preparation Phase 
 

1. Determine where on your computer you will store your captured images (referred to as “Science 
Images”) and the files resulting from your AIJ analysis. 

2. Create a directory tree containing the following directories: 
a. AIJ Analysis 

i. This is where AIJ process files will be kept 
b. Bias 
c. Darks 
d. Flats 
e. Quarantined Images 

i. These will contain images that are problematic 
f. Science Images 

i. This is where your “light” images will go – that is, the original images of the target. 
 

ii. Calibrated images will later be kept in a subdirectory (e.g., pipeline out_) under this 
directory. 

 
3. Ensure your bias, darks, flats, and science images from your imaging camera are loaded in 

the respective directories above. Note that, depending on the telescope providing your 
images the bias, dark and flat image calibration may have already been performed.  In this 
case these images are not needed. 

 
4. Exoplanet Worksheet 

a. This can be located at: astrodennis.com 
b. This worksheet contains data that will be used throughout your exoplanet project 
c. Fill in items 1-28 of the Worksheet. The other entries in the Worksheet can be filled in as 

you progress through the various phases. 
5. Open AIJ 

 
a. Open all of the Science Images by selecting from the main AIJ toolbar: File->Import->Image 

Sequence. 
 

b. If running on a Windows machine, select the first file in the Science Images directory, 
hit Open, and AIJ will load all images in that directory.  

c. If running on a Mac, select the subdirectory name. 
d. Hit OK. 
e. NOTE: If you receive an “Out Of Memory” message, you will also be given instructions for 

how to resolve this issue within the same message. Follow those instructions before 
proceeding. You may have to restart AIJ for the new settings to take effect. If this happens, 
restart this section from the beginning before proceeding on.  

 
6. Use the slider bar at the bottom of the Image Display to quickly review the quality of the images 

for any that are “bad” and should be excluded. “Bad” includes ones that are unreadable, have 
motion or focus problems, have satellite or meteor trails, etc. Move the bad images to the 
Quarantined directory. 



 
7. If the Science Images are not closely aligned image-to-image, see the appropriate sections in the 

Practical Guide (astrodennis.com) for how to deal with misaligned images, as well as dealing 
with a meridian flip8 

 
8. Open one of the science images by selecting File->Open from the main AIJ toolbar and navigating 

to your Science Images directory, or use one of the images already open when the Image 
Sequence was opened: 

 
a. Select an image 
b. Hit OK 

 
9. In the window containing the single image, open the FITS header to attempt to locate a few 

essential items. Select Edit->Edit FITS Header. You will not actually be editing the header, but you 
just want to verify the information contained. 

 
a. Locate and note the keywords for your site’s latitude and longitude (e.g., something like 

SITELAT and SITELONG). 
 

i. Verify if those are the exact coordinates of where your Observatory is located images 
were obtained.  

j. If South latitude or West longitude contains a + symbol, when it really should include a 
- symbol, make a note of this. We will address this shortly. 

 
b. Locate and note the keywords for the image’s RA and DEC (e.g., something like RA_OBJ 

and DEC_OBJ, or OBJCTRA and OBJCTDEC). 
i. Verify these coordinates against the spreadsheet. 

 
c. Locate and note the keywords for Airmass, if included, and the date/time of 

the observation. 
d. Hit CANCEL. 

10. The Preparation Phase is now complete. 
 
 
B. The Calibration Phase 
 

1. Open AIJ, if not already open. 
 

2. Press the DP button from AIJ’s main toolbar, Figure 1, to start "Data Processing." Two windows 
will appear: the CCD Data Processor, Figure 2, window and the DP Coordinate Converter window, 
Figure 3. Unless otherwise noted, the following steps apply to the CCD Data Processor window. 

 
3. In the "Science Image Processing" dialog box, select the directory where COPIES of the science 

images have been stored. 
a. Ensure Enable and Sort Num are checked. 

 



b. Ensure the next dialog box to the right has the correct extension for the files. This needs to 
be typed in: *.fit or *.fits as appropriate for the files you will be analyzing. The * is used as a 
wildcard and must be included. If you do not know the file extension used, in Windows, 
you can open Explorer, right click on an file, open Properties and read the file extension by 
the line “Type of File”. 

 
c. When both fields are set, look to the right and ensure that the number displayed 

represents the total number of images in the directory you will be analyzing. If it does not, 
there is an error. This error is usually in the file extension type. 

4. "Filename Number Filtering" 
a. This is where you can filter out any bad images. 
b. If NO images are to be filtered out, then ensure that the ENBLE box is NOT checked. 
c. If filtering, check the ENABLE box and fill in the dialogue boxes as appropriate. 

5. Selecting Calibration Files - this applies to BIAS and DARK SUBTRACTION, as well as FLAT DIVISION 
a. BUILD: 

i. use  
ii. Don't use Build if a master calibration file is already created. 
iii. Ensure the "Build" checkbox is selected for Bias, Darks, and Flats. The selection of 

BUILD tells AIJ to create a "Master" file. This will un-grey the upper dialogue box in 
order to input the directory where the appropriate files are stored.  

iv. For the BUILD line in the Bias, Dark, and Flat sections, locate and select the directory 
where the files are stored. 

v. To the right of this directory input box, you will see another dialogue box that says: 
bias_, dark_, and flat_. Replace each of these words with the file extension that you 
determined in step 3 above. Input with a wildcard. Example: *.fits  

vi. When the file extension is inserted, ensure you see the number of files displayed to 
the right of that dialogue box. If it reads 0, either the file extension is wrong, or there 
aren’t any calibration files in the directory location. 

 
vii. Ensure "med" is selected for DARKS and FLATS. 

 
 

b. ENABLE: Ensure that the "Enable" dialogue box is selected for BIAS, DARKS, and FLATS 
 

i. Select the same directory as your calibration images. This will allow the master file to 
be placed there. 

ii. “Enable” means that the master files will be applied to the Science Images. 
iii. Enter the file names for the master files as: mbias.fits, mdark.fits, and mflat.fits. NOTE: 

Ensure the correct file extension is placed here. 
 

iv. Ensure the number to the far right is showing 0, as a master file has not yet been 
created. 

c. DARKS additional items: 
 

i. Select "Scale". This allows Dark files to be scaled to the exact exposure time the 
Flats were taken so that Darks can be subtracted from the master flat. 

ii. Select Debias. This does bias correction to the master. 



iii. NOTE: if dark masters are available from other programs, then make sure Build is 
not selected, Enable is selected, and the correct filename and directory are entered 
for where this master dark can be found. Also, select “scale.” If the master darks 
created outside of AIJ are not already bias subtracted, then “deBias” should not be 
checked (this, of course, assumes that Bias Subtraction is also enabled). If master 
darks created outside of AIJ are already bias subtracted, then “deBias” should be 
checked. 

 
d. FLAT additional item: 

i. Ensure "Remove Gradient" is selected. 
6. Image Creation 

a. Ensure Enable Linearity Correction and Remove Outliers are NOT selected. 
 

b. These are to only be used if the Filename Number Filtering section is used. If so, 
reference section 6.3.2.1 and 6.3.2.5 of the AIJ Guide located at astrodennis.com. 

 
7. FITS Header Updates 

a. Use this section to have AIJ add information to the FITS header, as necessary. 
b. Ensure General is checked. 
c. Ensure Plate Solve is unchecked. 

 
d. Select FITS header editor (crescent wrench icon). The General FITS Header Settings 

window will appear: 
i. In the top window, FITS Header Input Settings 

 
1. If the observatory’s Latitude or Longitude in your FITS headers had a + symbol 

when they should have had a -, ensure that the appropriate “negate” box is 
checked. 

 
2. Ensure that the keywords that are in your FITS headers for RA and DEC and for 

latitude and longitude (see Step 9 under Preparation Phase above) are entered 
into their respective fields as they appear in your FITS headers. 

 
ii. In the FITS Header Output Settings section 

1. Ensure all boxes are enabled except if the .fits header of your files already 
contains the AIRMASS keyword this enable box should not be checked. 

 
2. Make sure that the keyword entered next to “BJD(TDB) mid-Obs Keyword” is 

BJD_TDB and not BJD_UTC. 
iii. Close the General FITS Header Settings window. 

 
e. If your FITS header contains keywords for RA and DEC, then in the Target Coordinate Source 

dropdown, select “FITS header target RA/DEC (J2000).” Otherwise, select “Coordinate 
Converter manual entry.” If you selected the latter, then you will be able to enter the RA 
and DEC on the DP Coordinate Converter window. 

 
f. If your FITS header contains keywords for Latitude and Longitude, then in the Observatory 

Location Source dropdown, select “FITS header latitude and longitude.” Otherwise, select 



“Coordinate Converter manual entry.” If you selected the latter, then you will be able to 
enter your observatory’s location information on the DP Coordinate Converter window. 

 
g. For more information on manual entries of coordinates or location, see Section 7.2.2.1 of 

the Practical Guide. For more information on selecting the FITS header keywords, see 
Section 7.2.2.4 of the Practical Guide. 

 
8. On the DP Coordinate Converter window, Figure 3, make sure that the appropriate settings 

are made so that AIJ can correctly compute BJD_TDB: 
a. Locate the Dynamical Time section. 
b. Check the Auto checkbox. 
c. Check the Update button. Hit OK. 

9. In the CCD Data Processor window, Figure 2, located Save Calibrated Images 
a. Ensure Enable is selected. 
b. Select “32” for 32-bit, if this is what your CCD uses. 

 
c. Type in the name of the subdirectory for the calibrated files (e.g., pipelineout_). This will 

place a new subdirectory in your main Science Images directory for the calibrated files. 
d. Type the calibration file suffix desired. Example: _out. 

10. Post Processing 
 

a. This section enables each image to have the World Coordinate System (WCS) coordinates 
embedded into the image. NOTE: This is optional for exoplanet analysis and photometry 
but WCS calculation may be necessary if there are large changes in the frame to frame 
LOS in your image sequence.  Image alignment may also be used to mitigate this problem.  
If selected, this step can take a long time as each image will be WCS processed individually 
through astrometry.net. If this is to be accomplished, reference the WCS Process guide in 
Section 7.4 in the Practical Guide. 

 
11. Control Panel 

a. Ensure POLLING INTERVAL is set to 0. 
12. Hit START when ready 

 
a. You should see a Log File appear, as well as the calibrated science images scrolling by. 

The Log File will show the steps involved in the creation of the masters, as well as the 
calibration of each science image, and the adjustments made to the FITS header (e.g., 
for BJD time, Airmass, etc.). 

 
13. When complete, ensure you save the Log File in to your AIJ Analysis directory. 
14. The Calibration Phase is now complete. 

 
 
 
  



 

C. Differential Photometry Phase 
 

1. Optional: If you are a member of the AAVSO, you may first want to access the AAVSO Variable Star 
Plotter program at https://www.aavso.org/apps/vsp/ to obtain the magnitude and stellar types of 
possible comparison stars to be used during the differential photometry process. 

 
a. Input the RA and DEC of your observation from the FITS header. 
b. Set the Chart Scale to desired. 
c. Set Chart Orientation to CCD. 
d. Set Plot a Finder Chart to Photometry. 
e. Hit PLOT CHART 

 
i. This chart can be used to identify known magnitudes of potential comp stars 

and whether any stars in the field are variable. 
ii. It is possible that the RA/DEC coordinates may not have any comparison stars in 

the vicinity that are known to the AAVSO. 
 

2. If not already open, open the range of calibrated images from the calibration subdirectory (e.g., 
pipelineout_) by selecting from the main AIJ toolbar: File->Import->Image Sequence 

 
a. If running on a Windows machine, select the first file in the calibration subdirectory, hit 

Open, and AIJ will load all images in that subdirectory.  
b. If running on a Mac, select the subdirectory name. 

 
c. Hit OK. 

3. Target Location 
a. The target star can be found in a number of ways: 

i. The easiest (if the image has been plate solved) is to locate the RA/Dec of the target 
from the FITS Header and match the cursor RA/Dec location against the target 
RA/Dec. 

ii. Another means can be to use AAVSO plotting charts as previously mentioned. 
iii. Software planetarium programs can also be useful. 

b. If the image is not plate solved with WCS coordinates, this can be accomplished through the 
WCS menu option on the image window, Figure 4. 
i. Click on WCS – Plate Solve Using Astrometry.Net 
ii. Blue circles will appear letting you know it is plate solving. The main AstroImageJ 

window, Figure 1, will provide a status update during this process. 
iii. Once it is complete, the blue circles will turn yellow and catalog names will appear 

above stars that have been identified in this process. Also, the AIJ main window, 
Figure 1, will say “Plate Solve Finished” 

iv. With the plate solve complete, you can match the FITS Header target RA/Dec 
against RA/Dec in the image to locate the target star. 

4. Left click on the target star in the image. You will not see any activity, until you then: 
 

a. Select Analyze->Plot seeing profile. Alternatively, you can place your cursor on the target 
star and then hit Alt/Left Click. The Seeing Profile7 Window will appear, Figure 5. 

https://www.aavso.org/apps/vsp/
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b. Record the following values: Radius, Back>, and Back< 
i. These will be used to define the (initial) annulus and aperture. 

c. Save and close the Seeing Profile window. 
 

5. In the Image Display Window, Figure 4, select the multi-aperture photometry settings icon (the 
icon with two circles on it). The Multi-Aperture Window will appear, Figure 6. 

 
a. On the Multi-Aperture Measurements screen, ensure that the First Slice and Last Slice 

represent the total number of images in your calibration subdirectory (e.g., pipelineout_). 
 

b. Ensure that Radius of object aperture8, the Inner radius of background annulus, and 
the Outer radius of background annulus entries are set with the Radius, Back> (Inner 
Radius of background annulus), and Back< (Outer radius of background annulus) 
values, respectively per the Seeing Profile in the step above. 

 
c. Ensure that the only other boxes checked are: Centroid apertures (initial setting) and 

Remove stars from Background. 
 

d. Click on the Aperture Settings button at the bottom. The Aperture Photometry Settings 
screen will appear, Figure 7. 

 
e. Ensure that the only boxes checked are: Centroid apertures, Use Howell centroid method, 

Remove stars from background, Use exact partial pixel…, List the following FITS keyword…, 
Saturation warning, and Linearity warning. 

 
f. Next, input settings relative to your CCD camera that were used to acquire the 

Science Images 
i. Ensure that the following are set for your CCD Camera: 

1. CCD gain 
2. CCD readout noise 
3. CCD dark current per sec 

 
(Note: if you had binned your CCD camera to something other than 1x1, then 
enter the adjusted values for the binning you have selected.) 

 
ii. For Saturation warning, ensure that a value is entered for the saturation point of 

the CCD camera being used. 
 

iii. For Linearity warning, enter the ADU value where your CCD camera becomes 
non-linear. 

 
iv. Hit OK, which will return you to the Multi-Aperture Measurements screen, then 

hit Place Apertures. If you had AIJ plate solve and you see the yellow star 
identification circles, those will disappear when you hit OK. 

 
5. With your mouse, first select the target star. Verify that the it turned green and is labeled with 

a T#. 
6. Select the comp stars. These will be labeled with a C#. 



7. Hit Enter key, or right click, to start the differential photometry process. 
8. A Measurement Table will be created, Figure 8, that will, once the processing is complete, contain: 

 
a. A top header row and then a row for each image. The Source-Sky and Rel_flux columns are 

described below. The meaning of the other columns are described in: 
https://arxiv.org/abs/1601.02622. 

 
b. Source-Sky_XX 

 
i. ADU counts in the aperture, with the ADU counts for the background sky in the 

annulus subtracted out. Hence the Source - Sky name. 
c. Rel_flux_XX 

 
i. If XX=T1, this refers to the relative flux of T1, which equals Source-Sky_T1 divided 

by the Source - Sky counts for all of the comp stars. 
 

ii. If XX=Cn, this refers to the relative flux of Cn (the n’th comp star), which equals 
Source-Sky_Cn divided by Source – Sky counts for all the other comp stars. Note 
that the target star’s Source - Sky counts are not included in the denominator for 
the relative flux numbers for the comp stars. 

 
9. Save the Measurement Table in the AIJ Analysis directory. 
10. This completes the Differential Photometry Phase. 
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D. Transit Modeling Phase 
 

1. Load and unzip the following AIJ plot configuration file from http://astrodennis.com: 
Measurements_Template.plotcfg (NOTE: This might be listed as a ZIP file). Store it in the 
AIJ Analysis subdirectory, and NOT in the C:/Programs directory. Unzip to this directory if 
needed. 

 
2. Open the Measurements file from the Differential Photometry Phase. From the main AIJ 

toolbar, Figure 1, select File->Open and then the Measurements file that was saved above. 
a. Minimize the window when it opens. 

3. Select the MultiPlot icon on the main AIJ toolbar (looks like a graph with a sine wave) 
a. When you select this, a series of 4 windows will appear: Plot of Measurements (Figure 9), 

Multi-plot Y-data (Figure 10), Multi-plot Reference Star Settings (Figure 11), and Multi-plot 
Main window (Figure 12). 

4. From the "Multi-plot Main" window, Figure 12: 
a. Select File->Open Plot Configuration from file… 

 
b. Select the Measurements_Template.plotcfg file from the AIJ Analysis directory 

mentioned above. 
c. The open windows will refresh, and another window will open, Data Set 2 Fit Settings, 

Figure 13. 
 

d. If changes are later made to the template .plotcfg file, then you can save this revised .plotcfg 
by selecting File->Save plot configuration…, name the file and save it. 

e. In the Multi-plot main window, Figure 12, locate the Data section at the top of the screen 
and fill in the following fields: 
i. Default X-data: Set to BJD_TDB. 

ii. Y-datasets: Set to 37. 
 

iii. Set V.Marker 1 and V. Marker 2 to the predicted ingress and egress times, 
respectively. These values can be found on your Worksheet. This will establish 
markers on the graph showing where the expected beginning and end of the light 
curve dip shall should occur. 

 
iv. At the bottom, locate the section called Fit and Normalize Region Selection. This 

establishes a pre-ingress and post-egress baseline for the model fit and should be 
initially set to the predicted ingress and egress times. Click on Copy (looks like two 
arrows moving left and right). This will pull in the V. Marker 1 & 2 values from above. 

 
v. Before doing the next step, make sure that the Plot box for the first row of the Multi-

plot Y-Data screen, Figure 10, is checked. 
 

vi. Back on the Multi-plot Main screen, Figure 12, go to X-Axis Scaling and select Auto X-
Range, then click on the blue arrow pointing to the right. This will automatically find 
the minimum and maximum X axis values that are in the Measurements table and/or 
the V.Marker and baseline regions. So, for example, if your observation started after 

http://astrodennis.com/


the predicted ingress time, this will pick up the minimum X value from the left entry of 
the Fit and Normalize region. If desired, these minimum and maximum values can be 
overridden by selecting Custom X-range and manually entering them. 

 
f. Locate the Title section 

i. Ensure that Custom is selected. 
ii. Name the model – e.g., WASP-12b on UT2016-01-06. 

g. Locate the Subtitle section 
i. Ensure that Custom is selected. 

ii. Enter your name, filter, and science image exposure time. 
 

h. Locate the Meridian Flip section. Use this if there was a meridian flip, or there was a 
discontinuity in imaging where the target star ended up on a different portion of the 
detector. If it is used, ensure that Show is checked and the decimal part of the time of the 
occurrence is entered. 

 
 

5. On the Multi-plot Y Data window, Figure 10, the following should be done to properly control 
what is being plotted: 

 
a. In the third column from the left labelled “Plot,” place a check mark for each of the values 

titled in the Y-Data column that you want plotted. Y-data is the 7th column from the left 
side. 

b. Set the color and symbol for each plot to your taste. 
c. For Fit Mode: 

 
i. These selections tell AIJ what type of model fit, if any it should apply to the 

dataset you have selected in the Y-data column. 
 

ii. For the first row, ensure that the relative flux of the target star (may appear as 
rel_flux_T1) is titled under the Y-Data column (column 7). Then set the Fit Mode to 
"Off" for this first row. This will cause AIJ to graph the data without doing a fit. 

 
iii. For the second row, again ensure that the relative flux of the target star is selected 

under the Y-Data Column, but now set the Fit Mode to what looks like an exoplanet 
dip icon. 

 
iv. For every comp star data set located in the Y-data column (column 7), set the 

Fit Mode to a straight line. 
d. Go to the Norm/Mag Ref column: 

 
i. For both rows for the target star (ex. rel_flux_T1 and rel_flux-T2), select the icon with 

green bars on the left and right, with a white bar in the middle. This establishes the 
left and right regions specified in the Fit and Normalize Region Selections values 
entered on the Multi-plot Main screen that will be used normalize the plot in the 
middle. 

 
ii. For the comp stars, select the icon that is all green. 



 
e. The meaning of other columns, such as Scale and Shift, can be seen by hovering your mouse 

over the column name. 
6. Go to the Data Set 2 Fit Settings window, Figure 13. This is where you will enter values that AIJ 

will use to do its exoplanet transit model fit, as well as if and how residuals are displayed. 
 

a. If this window does not appear, go back to the Multi-plot Y-data, Figure 10, screen and 
make sure that the transit model icon is selected from the Fit Mode column. 

b. Under Orbital Parameters, enter the Period per the data from your Worksheet. 
 

c. Under Host Star Parameters, enter for R*(Rsun) the radius of the target star from your 
Worksheet. If the radius is not known, enter the spectral type (Sp.T.) of the host star. 

d. In the Transit Parameters section: 
i. Ensure Enable Transit Fit is checked. 

ii. Ensure Auto Updates Prior is checked. 
 

iii. Enter the limb darkening coefficients, Linear LD u1 and Quad LD u2 along the left side 
of the window. Ensure that the LOCK boxes for these items are selected. 

7. Return to the Multi-plot Main window, Figure 10: 
 

a. In the Y-axis Scaling section, you can adjust the Y-max and Y-min values to adjust the plots 
on the Plots display. 

b. In the X-axis Scaling section, it is best to leave Auto X-range selected. 
 

8. Locate the Multi-plot Reference Star Settings window, Figure 11. This is used to deselect or 
select which comp stars will be included in the model fit. For example, if a comp star does not fit 
a linear path, it may be a variable star and thus would need to be excluded. 

 
9. Review Section 7.11 of the Practical Guide to choose the appropriate Detrend parameters and 

to further optimize your model fit. 
 

10. On the Multi-plot Main screen, Figure 10, select File->Save all.. to save your work to the 
AIJ Analysis directory. 


