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The following are step-by-step instructions for using AstroImageJ (AIJ) to perform the 
reduction and analysis of a Las Cumbres Observatory (LCO) exoplanet observation processed 
through the OSS Pipeline. Many thanks to Grady Boyce of the Boyce Research Initiatives and 
Education Foundation (B.R.I.E.F – www.boyce-astro.org) for creating the predecessor to this 
Guide which is called the AIJ Cookbook and is available at www.astrodennis.com.  Comments 
on and suggestions for improvements to the instructions below can be forwarded to 
info@boyce-astro.org. A link to the latest version of these instructions can be found at the 
Boyce-Astro website. http://boyce-astro.org/brief-exoplorer-program/exoplanet-observation-guides/. 
 
These instructions supplement Section 7.0 of “A Practical Guide to Exoplanet Observing,” a link 
to the latest version of which can be found at www.astrodennis.com and which will be 
referred to in the instructions below as “the Practical Guide.” Note that the instructions below 
are not a substitute for the Practical Guide, but rather are a supplement to it. Reference will 
also be made below to “the Worksheet” – this is the worksheet depicted in Appendix A of the 
Practical Guide and which, when filled out per the instructions in the Practical Guide, will be 
useful in conducting the phases described below. 
 
In addition to the Practical Guide, reference will sometimes be made to AstroImageJ’s own 
guide, which can be found at www.astro.louisville.edu/software/astroimagej/ and which will 
be referred to here as “the AIJ Guide.” 
 
Some text in this guide will differentiated with red, underlined textx and a number in 
superscript. This indicates a file required for upload to ExoFOP-TESS or ExoFOP-K2. The number 
in superscript indicates which file this correlates to in the TFOP_SG1_Guidelines. Notes specific 
to Boyce-Astro Exoplorers are in red boxes located at the appropriate point in the procedures. 
 
IMPORTANT: AIJ will remember settings from previous runs. It is important to follow this Guide 
by the letter as this will reset all settings to what you will need for each new run, thus avoiding 
confusion with settings from previous AIJ sessions.   

http://www.boyce-astro.org/
http://www.astrodennis.com/
mailto:info@boyce-astro.org
mailto:dennis@astrodennis.com
http://boyce-astro.org/brief-exoplorer-program/exoplanet-observation-guides/
http://www.astrodennis.com/
http://www.astrodennis.com/
about:blank
about:blank
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Preparation Phase 
 

1. Determine where on your computer you will store your captured images (referred to as “Science 
Images”) and the files resulting from your AIJ analysis. 
 

2. Create a directory tree containing the following directories in Figure 1: 

 

 
a. AIJ  Analysis 

i. This is where AIJ process files will be kept 
b. Bias 
c. Darks 
d. Flats 
e. Quarantined Images 

i. These will contain images that are problematic 
f. Science Images 

i. This is where your “light” images will go – that is, the original images of the target. 
ii. Calibrated images will later be kept in a subdirectory (e.g., pipeline out_) under this 

directory. 
 

Exoplorer Note: this set of folders are pre-made, are in the Latest Instructions Folder, and called New 
Analysis Template Folder – blank. Copy that folder into your Run Folder. 

Figure 1 Recommended folders for any AIJ exoplanet analysis 

ExoFOP-TESS: 
• It is recommended that you print and save a copy of the TESS Transit Finder (TTF, 

Figure 2) for reference during your AIJ analysis. You may need to separately save a 
copy of the Notes from the TTF to have a complete copy available for reference later.  

• The information needed for the Exoplanet Worksheet (Figure 3) can be located at the 
ExoFOP website, observatory and camera websites, FITS header, and the Ohio State 
online calculator link on the worksheet. The ExoFOP data is provided when you click 
on the link provided under the “NAME” column in the “Info” section of the TTF page. 

• Double check the RA/Dec between the FITS header and the TTF Website to ensure 
accuracy 
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Figure 2 TESS Transit Finder (TTF) results page for one transit 

 
3. Ensure your bias, darks, flats, and science images from your imaging camera are loaded in 

the respective directories above. Note that, depending on the telescope providing your 
images the bias, dark and flat image calibration may have already been performed.   In such 
cases these calibration images are not needed.  This Guide assumes you have set up folders 
such as in this Figure 2 regardless of whether the Bias, Darks, and Flats are to be used. 
 

4. Prepare the Exoplanet Worksheet (Figure 3). 
a. A general template can be located at: astrodennis.com 
b. The Worksheet contains data that will be used throughout your exoplanet project 
c. Fill in items 1-28 of the Worksheet. The other entries in the Worksheet can be filled in as 

you progress through the various phases. 

 

Exoplorer Note: The TTF copy will be provided in your Run Folder. Review the dip PPT and the 
notes to estimate whether the run will most likely be a Case 1, 2, or 3 in the Observation 
Guidelines. The calibrations have been completed for OSS Pipeline processed images so you will 
leave the Bias, Darks, and Flats folders in Figure 1 empty. 

o Exoplorer Note: A partially completed Worksheet for LCO-OSS processed images is 
contained in the Latest Instructions folder. The Worksheet is color coded for the 
sources of data. Copy this template into your Run folder and complete lines 1 through 
28 before starting. The rest can be completed as you go. Cadence of your image run. 
(Calculate by dividing the total run duration by the number of images in the run. LCO 
0.4m scopes with the SBIG CCD have a 14 second overhead. Use this and your 
exposure time to confirm your cadence calculation). Host Star Spectral Type, or the 
Effective Temperature (Teff), log (g), [Fe/H]. These may be obtained from GAIA or 
ExoFOP (see example in Figure 4). There is a link to it under the NAME column. 
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Data you will need to know for your run and the Worksheet include: 
o RA/Dec, Date of observation 
o Predicted Ingress/Egress (expressed as a fraction of the BJD-TDB day). You don’t need first three 

characters 
o Where observing from, except altitude 
o Make/Model of camera 
o CCD Parameters: Gain (e-/count), Readout Noise (e-), Dark Current per Sec (e-/pix/sec), 

Saturation point, Linearity point. 
o Cadence of your image run 
o Limb Darkening Coefficients: use data from ExoFOP for the star to enter into the web calculator 

at http://astroutils.astronomy.ohio-state.edu/exofast/limbdark.shtml 
o Pixel Size 
o Plate Scale/Image Scale 
o Binning 
o Exposure Time 
o Filters 
o FOV arcmins 
o FWHM from AIJ Aperture Window (comes later) 
o Host Star Radius (This may be obtained from GAIA as well as ExoFOP) 
• Host Star Spectral Type, or the Effective Temperature (Teff), log(g), and [Fe/H] 

Figure 3 Exoplanet Worksheet 

http://astroutils.astronomy.ohio-state.edu/exofast/limbdark.shtml
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Figure 4. Example ExoFOP page for a TIC 
 

 
5. Open AIJ 

a. Update AIJ to the Daily Build. Go to “Help” and “Update AstroImageJ”. In the box “Upgrade 
to:” slide the scroll bar to the top, click on “daily build” and click on OK.  
 

 
Figure 5 AIJ Main Toolbar 

 
b. Open all of the Science Images. Select from the main AIJ toolbar: File->Import->Image 

Sequence. 
o If running on a Windows machine, select the first file in the Science Images directory, 

hit Open, and AIJ will load all images in that directory.  
o If running on a Mac, select the subdirectory name. 

c. Hit OK. 
d. NOTE: If you receive an “Out Of Memory” message, you will also be given instructions for 

how to resolve this issue within the same message. You will need to check the box labeled “ 
Use virtual stack”. Follow those instructions before proceeding. You may have to restart AIJ 
for the new settings to take effect. If this happens, restart this section from the beginning 
before proceeding on.  

 
6. Use the slider bar at the bottom of the Image Display to quickly review the quality of the images 

for any that are “bad” and should be excluded. “Bad” includes ones that are unreadable, have 
motion or focus problems, have satellite or meteor trails, etc. Move the bad images to the 
Quarantined directory. 
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Figure 6 AIJ Image Display 

 
 

 
7. If the Science Images are not closely aligned image-to-image, see the appropriate sections in the 

Practical Guide, Section 7.5.3 (astrodennis.com) for how to deal with misaligned images, as well 
as dealing with a meridian flip.  

 

8. Open one of the science images by selecting File->Open from the AIJ Main Toolbar and navigating 
to your Science Images directory, or use one of the images already open when the Image 
Sequence was opened: 

a. Select an image 
b. Hit OK 
c. In the window containing the single image, open the FITS header to attempt to locate a few 

essential items. Select Edit->Edit FITS Header. You will not actually be editing the header, 
but you just want to verify the information contained. 

d. Locate and note the keywords for your site’s latitude and longitude (e.g., something like 
SITELAT and SITELONG). 

1) Verify if those are the exact coordinates of where your Observatory is located images 
were obtained.  

2) If South latitude or West longitude contains a + symbol, when it really should include a 
- symbol, make a note of this. We will address this shortly. 

Exoplorer Note: LCO 0.4m scopes are not guided so misalignment occurs. The OSS Pipeline images are all 
plate solved and the misalignment can be overcome in the Differential Photometry phase procedure.    
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e. Locate and note the keywords for the image’s RA and DEC (e.g., something like RA_OBJ 
and DEC_OBJ, or OBJCTRA and OBJCTDEC). 

1) Verify these coordinates against the spreadsheet. 
f. Locate and note the keywords for Airmass, if included, and the date/time of 

the observation. IMPORTANT: For non LCO images, you may need to convert 
the date/time to UT if the CCD FITS Header does not already provide this 
information.  

g. Hit CANCEL. 
 

9. The Preparation Phase is now complete.  [Good place for a BREAK.] 
 

B. The Calibration Phase 
 

1. Open AIJ, if not already open, to see the AIJ Main Toolbar. 
 

2. Press the DP button on the AIJ Main Toolbar, Figure 5, to start "Data Processing." Two windows 
will appear: the CCD Data Processor, Figure 7, window and the DP Coordinate Converter window, 
Figure 11. Unless otherwise noted, the following steps apply to the CCD Data Processor window 
or the windows opened from it. 

 
 
 

 
Figure 7. CCD Data Processor Window 
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2. a. Make your CCD Data Processor window follow the highlights here and these specific notes: 

A – Point to your Science Image folder 
B – Look at an image file and be sure to that the extension matches – OSS should be *.fit 
C – You will not have your A and B entries correct until the correct number of images is displays 
here.  
D– Click on the wrench and see step 2.b. You will need to correct the labels that AIJ looks for in 
the FITS header for the LCO / OSS processed images 
E – You will return to this window to click START only AFTER you have completed the settings on 
the following pages (through Step 3). 

 
[Note: For LCO images, check the 32 bit, not 16 bit, box in the “Save Calibrated Images” section.] 
 

 
Figure 7A. CCD Data Processor Window for OSS processed images 

 
 

 

Exoplorer Note: The OSS Pipeline has performed the calibrations and plate solving described in 
this Phase. The FITS Headers will need to be modified to conform to AIJ’s needs. The old steps 3 
through 7 and 9, 10, and 11, are replaced with instructions below. 
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2. b. When you click on the wrench icon, the General FITS Header Settings window (Figure 8) will appear. 
For LCO / OSS files, you should change the default General FITS Header Settings that first appear to 
these. If you are unsure of any of these settings, see 2.c. for how to read your FITS Header. 

 
2. c. To see your FITS header, open a science image, 
click on Edit, and select Edit FITS header  

Change the FITS Header Input Settings to 
match these that should match the labels 
in your FITS Header files from OSS. 
 
Be sure to check the Degrees box. 
 
 
 
 
If your observatory is west of the prime 
meridian and east of the international 
dateline, then its longitude should  be 
negative. If your FITS header displays 
West longitude as a positive number, 
then you should check the “negate” box 
to indicate to AIJ that the number found 
in the FITS header should really have a 
negative sign associated with it. This 
should be the case for LCO / OSS images, 
but you should check this to confirm.  
 
If your FITS header has AIRMASS data, 
you should uncheck this box so that AIJ 
does not overwrite that data. LCO / OSS 
images should have AIRMASS data. 
. 
Be sure time keyword is BJD_TDB so AIJ 
creates the correct FITS header data.  
 

Figure 8 General FITS Header Settings 

Figure 9 Top of Image Display Window 
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Figure 10: Note the LONGITUD field is correctly negative for a west of the prime meridian location. The 
location for LCO images is defined by the INSTRUME field that in this case is kb26 – the camera located 
at Cerro Tololo in Chile. To find other fields such as RA and Dec, you may need to scroll down the page a 
good degree. After you have done the calibration, it is good practice to do a sanity check of the added 
keywords. They will be at the bottom of the FITS Header. 
 

 
 
 
 
 
 
 
 
 

Figure 10 Example LCO-OSS FITS header page 1 
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3. On the DP Coordinate Converter window, Figure 11, make sure that the appropriate settings 
are made so that AIJ can correctly compute BJD_TDB: 

a. Locate the Dynamical Time section. 
b. Check the Auto checkbox. 
c. Check the Update button. Hit OK. This can take a few seconds. If there is an error message, 

click on Network at the top and be sure that “Use proxy server for internet access” is 
checked. Try again. 
[NOTE: the USNO website may not be accessible while it is undergoing major updates from 
November, 2019 through April, 2020. If unable to reach USNO, use 32.0 in the Leap-secs 
box.] 
 

 
 

Figure 11. DP Coordinate Converter 
 
 

4.     On the CCD Data Processor window, click START when ready. 
d. You should see a Log File appear, as well as the calibrated science images scrolling by. 

The Log File will show the steps involved in the creation of the masters, as well as the 
calibration of each science image, and the adjustments made to the FITS header (e.g., 
for BJD time, Airmass, etc.). 

 
5.  When complete, ensure you save the Log File in to your AIJ Analysis directory. 
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ExoFOP-TESS: 
 
You should have each image orientated with North up, and East left. To do this…. 

• Select the first frame in your Pipelineout file and open it. 
• In the image window, select the VIEW menu. 
• Select Invert X, Invert Y, or Invert X and Y as necessary 

ExoFOP-TESS: 
 
For TESS observations, at least one image must be plate solved with WCS to enable the some of the 
ExoFOP reports but not all images need to be plate solved. See Section 7.4 of A Practical Guide for 
how to do this in AI. OSS processed images are plate solved so this step can be ignored.  
 

 

6. The Calibration Phase is now complete. You can take a break safely at this point. 
 
 
Differential Photometry Phase 
 
1.  Optional: If you are a member of the AAVSO, you may first want to access the AAVSO Variable Star 
Plotter program at https://www.aavso.org/apps/vsp/ to obtain the magnitude and stellar types of 
possible comparison stars to be used during the differential photometry process. 
a. Input the RA and DEC of your 
observation from the FITS header. 
b. Set the Chart Scale to desired.                              
c. Set Chart Orientation to CCD.  
d. Set Plot a Finder Chart to Photometry. 
e. Hit PLOT CHART 
i. This chart can be used to identify known magnitudes of potential comp stars and whether any stars in 
the field are variable. Use this in Step 9 below. 
ii. It is possible that the RA/DEC coordinates may not have any comparison stars in the vicinity that are 
known to the AAVSO. 

Exoplorer Note: The OSS Pipeline has performed the plate solving on all images so doing an AIJ 
plate solve is unnecessary. 

Exoplorer Note: You do not need to do this step.  The OSS 
Pipeline files will include recommended comp stars based on a 
thorough analysis of the stars in your image run FOV. 
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2. Use Method 1: use the TTF link: The TTF (Figure 1) now includes a link labelled “AIJ apertures” in the 
Name column for each TTF entry. Clicking on this link will cause the aforementioned *.radec aperture 
file to be generated for the target represented by the entry. Save this file to the AIJ Analysis folder.  
 
3. Open the range of calibrated images from the calibration subdirectory (e.g., pipelineout) by selecting 
from the  AIJ Main Toolbar: File->Import->Image Sequence 

a.If running on a Windows machine, select the first file in the calibration subdirectory, hit Open, 
and AIJ will load all images in that subdirectory. Be sure to check “Use virtual stack”. 
b. If running on a Mac, select the subdirectory name. 
c. The Sequence Options window will appear. Confirm that AIJ is recognizing all the images in 
your folder.  
d. Check “Sort names numerically” and “Use virtual stack” 
e. Click on OK 

 
4.        Target Location 

a. The target star can be found in a number of ways: 
i. The easiest way since the image has been plate solved by OSS is to locate the RA/Dec 
of the target from your target source information (Ex. KEPLER, GAIA, TESS, etc.). Move 
the cursor over the WCS solved image until the RA/Dec of the target star is matched in 
the RA and Dec windows in the AIJ Image Window.   
ii. Software planetarium programs can also be useful through looking for patterns of 
stars around the target star. 

5. . Left click on the target star in the image. You will not see any activity, until you then: 
a.Select Analyze->Plot Seeing Profile. Alternatively, you can place your cursor on the target star 
and then hit Alt/Left Click. The Seeing Profile Window will appear, Figure 12. 
b. Record the following values: Radius, Back>, and Back< 

i. These will be used to define the (initial) annulus and aperture. 
c. Save  in the AIJ Analysis folder. [Note this is an ExoFOP required file.] 
d. Close the Seeing Profile window. 
 

TESS observations have macros that can be installed in AIJ to facilitate in identifying Nearby Eclipsing 
Binaries (NEBs) that could create a false positive. These will become additional Target stars in the analysis. 
The macro automates the selection process by querying the Gaia database in the region of interest (2.5’) to 
create a set of apertures for those stars called a *.radec aperture file. See Appendix C in the TFOP SG1 
Guidelines located here for further explanation: http://astrodennis.com/TFOP_SG1_Guidelines_Latest.pdf 

Check to be sure these macros have been installed by opening File for an image. The option “Create NEB 
search reports and plots…” will be listed. If not, update AIJ per Preparation Phase, Step 5. 

The two methods for creating the *.radec aperture file are: use of a link in the TTF entry for a target, or use 
of a web-based tool. Method 1 is easier when you have the TTF page with its links. Refer to the Guidelines 
if you need to use the other method. 

 

http://astrodennis.com/TFOP_SG1_Guidelines_Latest.pdf
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Figure 12. Seeing Profile Window 
 
 
 

6.  Load the NEB Apertures. The NEB aperture file can be loaded from the Image Display by selecting 
File->Import apertures from RA/Dec list. Apertures are automatically created over those stars that 
needed to be checked as potential NEBs causing the TESS detection. They will be annotated as T’s with 
T1 being your target and the other T’s as possible causes for a false positive observation for T1. 
 

 
Figure 13 portion of AIJ Image Window 1 

Be sure the 3 boxes above the image starting with the one labeled C2 have been clicked and are gray 
(see Figure 13). 
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7. Annotate an image for the region of interest.  A circle of 2.5’ radius can be drawn around the target 
star (see Guidelines Appendix B as an example), by performing the following steps: 
 

a. Under Annotate at the top of the Image Display Window, make sure that the “Right click in 
image opens annotation dialogue” option is selected. 

b. Right click on the target star and a dialogue box opens up. 
c. For “Custom Text,” enter Radius=2.5’ 
d. Check only the Show Circle option 
e. Enter the number of pixels that equates to 2.5’ (i.e., 150 arc-seconds). For example, if the 

pixel scale is 1.5 arc-seconds per pixel, then 100 should be entered for the number of pixels. 
This information is available in your Worksheet. For LCO 0.4m telescopes with the SBIG 
camera (creates 0.57” pixel images), use 263. 

f. Clicking OK will then put a circle of radius 2.5’ around the target star. 
 
8.  In the Image Display Window, Figure 13, select the multi-aperture photometry settings icon (the 
icon with two circles on it). The Multi-Aperture Measurements Window will appear, Figure 14. 
 
 

 
 

Figure 14. Multi-Aperture Measurements Window 
 

a.     On the Multi-Aperture Measurements window, ensure that the First Slice and Last Slice 
represent the total number of images (the first image through the last image) in your calibration 
subdirectory (e.g., pipelineout_). 
b.      Ensure that Radius of object aperture, the Inner radius of background annulus, and the 
Outer radius of background annulus entries are set with the Radius, Back> (Inner Radius of 
background annulus), and Back< (Outer radius of background annulus) values, respectively per 
the Seeing Profile in the step above. 
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c.       Ensure that these boxes checked are: Centroid apertures (initial setting) and Remove stars 
from Background. Since NEB aperture targets have been created from the Gaia macros, be 
sure to check the box labeled “Use previous nn apertures”. For LCO images which are 
unguided but processed through the OSS Pipeline, check “Use RA/Dec to locate aperture 
positions”. You can also check “Update table and plot while running” to track your progress 
during the run and click “Show help panel…” if you wish. 
d.     Click on the Aperture Settings button at the bottom. The Aperture Photometry Settings 
screen will appear, Figure 15. 
 

 
 

Figure 15. Aperture Photometry Settings Window 
 

e.      Ensure that the only boxes checked are: Centroid apertures, Use Howell centroid method, 
Remove stars from background, Use exact partial pixel…, List the following FITS keyword…, 
Saturation warning and Linearity warning. 
f.      Next, input settings relative to your CCD camera that were used to acquire the Science 
Images 
    i. Ensure that the following are set for your CCD Camera: 

1. CCD gain 
2. CCD readout noise 
3. CCD dark current per sec 
(Note: if you had binned your CCD camera to something other than 1x1, then enter the 
adjusted values for the binning you have selected.) 

     ii. For Saturation warning, ensure that a value is entered for the saturation point of the CCD 
camera being used. 
     iii.  For Linearity warning, enter the ADU value where your CCD camera becomes non-linear. 
g. Hit OK, which will return you to the Multi-Aperture Measurements screen. 
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h. Hit Place Apertures. You will see all the T stars from the NEB aperture file appear in yellow. 

 
9.  Select the comp stars by left clicking on your desired comp star. These will be labeled with a C# (The # 
will change with each comp star you select. Example: C23, C24, C25, etc.). [Note: If you have placed the 
Gaia NEB apertures already, your Comp stars will continue numbering following the last T number, e.g. 
T8, T9, C10, C11…] A suggestion for good comp stars are those that are of similar apparent magnitude 
and color and are non-variable. You may need to refer to Gaia or Simbad to identify those of similar 
color. You may need to choose 6 to 10 comp stars; some of these may prove to be too variable to be 
used in your modeling. Having more will assure that you will have at least 3 to use in your modeling.  
 
10.  Save a screen grab of your image with the NEBS and Comps as a PNG file. [Note this is an ExoFOP 
required file. 
 
11.  Hit Enter key on your keyboard, or right click, to start the differential photometry process. 
 
12.  A Measurement Table will be created, Figure 16, that will, once the processing is complete, contain: 

a.  A top header row and then a row for each image. The Source-Sky and Rel_flux columns are 
described below. The meaning of the other columns are described in: 
https://arxiv.org/abs/1601.02622. 

b.  Source-Sky_XX.  ADU counts in the aperture, with the ADU counts for the background sky in 
the annulus subtracted out. Hence the Source - Sky name. 

c.  Rel_flux_XX If XX=T1, this refers to the relative flux of T1, which equals Source-Sky_T1 divided 
by the Source - Sky counts for all of the comp stars. If XX=Cn, this refers to the relative flux of 
Cn (the n’th comp star), which equals Source-Sky_Cn divided by Source – Sky counts for all the 
other comp stars. Note that the target star’s Source - Sky counts are not included in the 
denominator for the relative flux numbers for the comp stars. 

d.  Save the Measurement Table in the AIJ Analysis folder.  

Figure 16. Measurement Table Window after processing is complete. 

IMPORTANT NOTE: Typically, the circle annotation will be lost during this Step 8. If so, cancel out of 
the Multi-Aperture Measurements screens after you made all the right settings on those two 
screens but BEFORE you click on “Place Apertures”.  Return to Step 7 and set the circle annotation 
again. When that is completed return to this Step 8. Your last Multi-Aperture Measurement 
settings will have been saved by AIJ. You should not repeat Step 8. Go to Step 8.h. and click on 
“Place Apertures”. This procedure will enable making the screen grab in Step 8 with all the features 
required. 
 

https://arxiv.org/abs/1601.02622
https://arxiv.org/abs/1601.02622
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This completes the Differential Photometry Phase. Take a BREATHER! 
 
 
Transit Modeling Phase 
 

1. Load and unzip the following AIJ plot configuration file from http://astrodennis.com: 
Measurements_Template.plotcfg (NOTE: This might be listed as a ZIP file). Store it in the 
AIJ Analysis subdirectory, and NOT in the C:/Programs directory. Unzip to this directory if 
needed. 

 
2.  Open the Measurements file from the Differential Photometry Phase. From the main AIJ 

toolbar, Figure 1, select File->Open and then the Measurements file that was saved 
above. Or you can click on the icon that looks like a spreadsheet to the left of the DP icon. 
Minimize the window when it opens. 
 

3. Select the MultiPlot icon on the main AIJ toolbar (looks like a graph with a sine wave) 
a. When you select this, a series of 4 windows will appear: Plot of Measurements (Figure 17, 

Multi-plot Y-data (Figure 18), Multi-plot Reference Star Settings (Figure 19), and Multi-plot 
Main window (Figure 20 
 

 
Figure 17. Plot of Measurements. 

 

For OSS processed Measurement Tables created before November 2019, the order of the 
slices will not be sequential with BJD_TDB. The Measurement Table needs to be resorted. 
See the last 2 pages of Attachment A for the procedure. 

http://astrodennis.com/
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Figure 18. Multi-plot Y-data window. 

 
 
 

 
Figure 19. Multi-plot Reference Star Settings window. 

 

 
Figure 20. Multi-plot Main window. 
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4. From the "Multi-plot Main" window, Figure 20: 

a. Select File->Open Plot Configuration from file… 
b. Select the Measurements Template.plotcfg file from the AIJ Analysis directory mentioned 

above. 
c. The open windows will refresh, and another window will open, Data Set 2 Fit Settings, 

Figure 21. 
 
 
 

Figure 21. Data Set 2 Fit Settings window. 
 

d. If changes are later made to the Measurements_Template.plotcfg file, you can save this 
revised .plotcfg by selecting File->Save plot configuration…, name the file and save it. 

e. In the Multi-plot Main window, Figure 20 locate the Data section at the top of the screen 
and fill in the following fields: 
i. Default X-data: Set to BJD_TDB. 

ii. Y-datasets: Set to 37. 
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iii. Set V.Marker 1 and V.Marker 2 to the predicted ingress and egress times, 
respectively. These values can be found on your Worksheet. This will establish 
markers on the graph showing where the expected beginning and end of the light 
curve dip shall should occur. Only enter the fraction of the day, i.e. the digits 
following the decimal point. If the transit crosses into a new day, make the egress 
add 1 to the egress day fraction (if the egress day fraction is.123456, then set the 
egress to be 1.123456). 

iv. At the bottom, locate the section called Fit and Normalize Region Selection. This 
establishes a pre-ingress and post-egress baseline for the model fit and should be 
initially set to the predicted ingress and egress times. Click on Copy (looks like two 
arrows moving left and right). This will pull in the V. Marker 1 & 2 values from above. 
Click twice to get both fields copied from the V. Marker boxes at the top of the 
screen. 

v. Now locate the Multi-plot Y-Data screen. Ensure that the Plot box for the first row of 
the Multi-plot Y-Data screen, Figure 18, is checked. 

vi. Back on the Multi-plot Main screen, Figure 20, go to X-Axis Scaling and select Auto X-
Range, then click on the blue arrow pointing to the right. This will automatically find 
the minimum and maximum X axis values that are in the Measurements table and/or 
the V.Marker and baseline regions. So, for example, if your observation started after 
the predicted ingress time, this will pick up the minimum X value from the left entry of 
the Fit and Normalize region. If desired, these minimum and maximum values can be 
overridden by selecting Custom X-range and manually entering them. 

 
f. Locate the Title section 

i. Ensure that Custom is selected. 
ii. Name the model according to what you are studying. For example, WASP-12b on 

UT2016-01-06. 
 

ExoFOP-TESS: 
This name should be the same name as the name provided on the TTF. The Title should be the TTF 
Target name followed by the UT for the observation.   
 

 
g. Locate the Subtitle section 

i. Ensure that Custom, from above, is selected. 
ii. Enter your name, filter, and science image exposure time. 

h. Locate the Meridian Flip section. Use this if there was a meridian flip, or there was a 
discontinuity in imaging where the target star ended up on a different portion of the 
detector. If it is used, ensure that Show is checked and the decimal part of the time of the 
occurrence is entered. 

i.  
 

ExoFOP-TESS:  
The Subtitle should be your name followed by the filter used and exposure time. 
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5. On the Multi-plot Y Data window, Figure 18, the following should be done to properly control 
what is being plotted: 

a. In the third column from the left labelled “Plot,” place a check mark for each of the values 
titled in the Y-Data column that you want plotted. Y-data is the 7th column from the left 
side. Typically you will start with checking each Comp Star. 

b. Be sure that all the Y-data dropdown boxes specify relative flux of the target or comp star 
(rel_flux_T# or C#). 

c. Set the color and symbol for each plot to your taste. 
d. For Fit Mode: 

i. These selections tell AIJ what type of model fit, if any it should apply to the 
dataset you have selected in the Y-data column. 

ii. For the first row, ensure that the relative flux of the target star (may appear as 
rel_flux_T1) is titled under the Y-Data column (column 7). Then set the Fit Mode to 
"Off" for this first row. This will cause AIJ to graph the data without doing a fit. 

iii. For the second row, again ensure that the relative flux of the target star is selected 
under the Y-Data Column, but now set the Fit Mode to what looks like an exoplanet 
dip icon. 

 
iv. For every comp star data set located in the Y-data column (column 7), set the 

Fit Mode to a straight line. 
d. Go to the Norm/Mag Ref column: 

i. For both rows for the target star (ex. rel_flux_T1 and rel_flux-T1), select the icon with 
green bars on the left and right, with a white bar in the middle. This establishes the 
left and right regions specified in the Fit and Normalize Region Selections values 
entered on the Multi-plot Main screen that will be used normalize the plot in the 
middle.  

ii. For the comp stars, select the icon that is all green. 
e. The meaning of other columns, such as Scale and Shift, can be seen by hovering your mouse 

over the column name. 
 

6. Go to the Data Set 2 Fit Settings window, Figure 21. This is where you will enter values that AIJ 
will use to do its exoplanet transit model fit, as well as if and how residuals are displayed. 

a. If this window does not appear, go back to the Multi-plot Y-data, Figure 18, screen and 
make sure that the transit model icon is selected from the Fit Mode column. 

b. Under Orbital Parameters, enter the Period per the data from your Worksheet. 
 

ExoFOP-TESS: 
This data can be found in the TTF information provided for the star that you are plotting or from 
your Worksheet. 

 

ExoFOP-TESS:  
You will also have T (target) stars listed under T1 for each of the stars identified by Gaia as 
having potential for causing a false positive measurement of T1. You should not check Plot 
for these “Targets” but set everything else as if they are Comp Stars. 



©  Boyce Research Initiatives and Education Foundation   www.boyce-astro.org 
 
 

c. Under Host Star Parameters, enter for R*(Rsun) the radius of the target star from your 
Worksheet. If the radius is not known, enter the spectral type (Sp.T.) of the host star. 
NOTE: If you have the Teff of the Host Star, it will auto fill the Spectral Type.  

d. In the Transit Parameters section: 
i. Ensure Enable Transit Fit is checked. 

ii. Ensure Auto Updates Prior is checked. 
iii. Enter the limb darkening coefficients, Linear LD u1 and Quad LD u2 in the Prior 

Center column second from the left if you were able to compute them. Ensure that 
the LOCK boxes for these items are selected and that the numbers appear in the 
boxed in the Best Fit column (1st from left). If not available, use 0.3 for both fields.  

iv. In the Detrend Parameters section select click on the Use box in the first line and 
select Airmass from the dropdown list to its right in the Parameter Column.  

 
7. Return to the Multi-plot Main window, Figure 20: 

a. In the Y-axis Scaling section, you can adjust the Y-max and Y-min values to adjust the plots 
on the Plots display. 

b. In the X-axis Scaling section, it is best to leave Auto X-range selected. 
 

8. Locate the Multi-plot Reference Star Settings window, Figure 19. This is used to deselect or 
select which comp stars will be included in the model fit. For example, if a comp star does not fit 
a linear path, it may be a variable star and thus would need to be excluded. 
 
ExoFOP-TESS: 
To make your model and the light curve plot it is useful to shrink the Multi-plot Y Data window, 
Figure 18 to half screen. Then place the Plot of Measurements, Figure 17 also at half page size next 
to it. This screen layout allows you to make the plotting changes described below and elsewhere in 
the Multi-plot Y Data window and see the effect in the Plot of Measurements. You wil also want to 
have the Multi-plot Reference Star window, Figure 19 available.  
 Now review the plots for each Comp star you have designated. You will want to deselect 

those that fluctuate significantly. They may be plotted on top of each other and you will 
need to move each one up or down in to get a clear view. You do this moving the plot using 
the up or down arrows in the Shift Column in the right side of the Multi-plot Y-data screen. 
You can also blink them on and off with the Plot check box.  

 You will want to deselect those comp stars that visibly fluctuate significantly. In making 
these decisions you can reference the RMS value at the top of the plot to determine if a 
good fit was made for that star. Higher RMS values indicate poorer fit. 

 In the second line of the labels, you will see the data for the quality of the fit for T1. You will 
want to select and deselect Comp Stars per step 8 to get the best fit (i.e. lowest RMS). The 
RMS value is also shown in the Data Set 2 Settings window, Figure 21. Ideally, you will end 
up retaining three or more of the comp stars in your model. 

 Next, be sure that you have unchecked Plot for all the comp stars that were deselected. 
Also, adjust the colors of the selected stars for best visibility and distinction. Be sure the 
same scaling factor is used for all plots.  

 When satisfied, be sure the plot and legends are legible with Target, selected Comp Stars 
and the four standard plots at the bottom (Airmass, total counts, X(FITS) and Y(FITS)). Use 
the Shift Column function to spread out the curves. You can also zoom in and out on the plot 
and drag it with your mouse. 
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9.  Review Section 7.11 of the Practical Guide (www.astrodennis.com) to choose the appropriate 
Detrend parameters and to further optimize your model fit. Generally you will always use Airmass as a 

ExoFOP-TESS: Go to the Multi-plot Main window and click on File. In the dropdown list, click on 
Create NEB search reports and plots… A new window will open and you will need to complete as in 
this example Figure here.  
 

 
Figure 22 TFOP SG1 NEB Analysis Macro 

 
The cadence is the time between successive images. You can calculate this by adding the exposure 
time and the CCD overhead cycle time (time used to download the image data from one frame). Or 
you can take the difference in BJD_TDB between successive frames and calculate the seconds 
elapsed. It may be wise to do both to confirm your cadence entry. Leave the last box, multiple of 
RMS, set at 5. The other data can come from your Worksheet. 
 
When you click on OK it will ask you to select the measurement file that was used for the plots you 
have generated. Use the pipeline out file that you have used. When done, all the reports generated 
by the NEB analysis will be generated.  

http://www.astrodennis.com/
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detrend parameter which should have been automatically chosen by AIJ.  
 

 
10. On the Multi-plot Main screen, Figure 10, select File->Save all... to save your work to the 

AIJ Analysis directory. 
 

 Go OUT FOR A CELEBRATION – You’ve done! 
 
Come back later and compile your ExoFOP data files – see our separate instructions for that. 


	b.  Source-Sky_XX.  ADU counts in the aperture, with the ADU counts for the background sky in the annulus subtracted out. Hence the Source - Sky name.
	c.  Rel_flux_XX If XX=T1, this refers to the relative flux of T1, which equals Source-Sky_T1 divided by the Source - Sky counts for all of the comp stars. If XX=Cn, this refers to the relative flux of Cn (the n’th comp star), which equals Source-Sky_C...
	d.  Save the Measurement Table in the AIJ Analysis folder.

